Как поменять версию php в openserver
Перейти к содержимому

Как поменять версию php в openserver

  • автор:

Форум

Доброго времени суток. У меня сейчас стоит на openserver php7.1, мне нужно 7.3. Как обновить, подскажите пожалуйста? Видел две подобные темы на форуме созданные лет 5 назад, ответ был — снести и удалить заново. С каждой новой версией php, что ли удалять все, бекапить, качать гиг почти и ставить все заново? Я надеюсь за 5 лет нашли какой-то способ просто файлы новые закинуть или нет ?

artur737 Сообщения: 2 Зарегистрирован: 03 сен 2020, 03:13

Re: Как обновить php?

нашел ответ в этой теме.
viewtopic.php?t=5013
Большое спасибо, пользователю Ink0gnit0
В отличие от администрации, нормальный мануал написал. (или я в упор не вижу)

Форум

Здравствуйте,
Я пытался изменить версию php от php 5.3 на php 5.5
OpenServer\userdata\profiles\Default.ini
phpdriver=»PHP-5.5″
В результате, сервер не запускается.
Что надо делать?
Болшое спасибо!

//простите мой плохой русский

[upd=1413040985][/upd]
Я нашел, как изменить версию с интерфейса, но все равно.
Запускается на версия 5.3(4), не запускается на версия 5.5

Osvax Сообщения: 81 Зарегистрирован: 19 мар 2013, 00:54

emosms писал(а): Здравствуйте,
Я пытался изменить версию php от php 5.3 на php 5.5
OpenServer\userdata\profiles\Default.ini
phpdriver=»PHP-5.5″
В результате, сервер не запускается.
Что надо делать?
Болшое спасибо!

//простите мой плохой русский

[upd=1413040985][/upd]
Я нашел, как изменить версию с интерфейса, но все равно.
Запускается на версия 5.3(4), не запускается на версия 5.5

Как обновить версию php в Open Server до php 7.1.3?

JhaoDa

заходим в трей -> (рабочий стол — справа внизу, где часы) -> выбираем зеленый флажок опен сервера -> ПКМ -> настройки -> вкладка модули -> PHP -> в выпадающем списке выбираем нужную версию, если нужной нет в списке, то идем на ospanel.io и скачиваем с нужным модулем.

Ответ написан более трёх лет назад
Нравится 10 3 комментария

arutyunov

Ссылка только такая теперь: https://ospanel.io/
Кирилл Арутюнов, спасибо, исправил
Radiss @Radiss Автор вопроса

uncletobe, Это не сработало. Для проекта необходима версия «php»: «^7.1.3», у меня была установлена в модулях 7.0.14 в версии 5.2.2.0 Пришлось скачать OS версию 5.2.8 В модулях выбран php 7.2*64 Apache 7.2*62 В phpinfo также инфа о том, что версия 7.2

Но при запуске команды composer update в корне проекта:

Your requirements could not be resolved to an installable set of packages.
Problem 1 — This package requires php ^7.1.3 but your PHP version (7.0.14) does not satisfy that requirement. Problem 2 — laravel/framework v5.7.9 requires php ^7.1.3 -> your PHP version (7.0.14) does not satisfy that requirement. и т.д.

В параметрах был изменен путь и версия php: Компьютер -> Свойство системы -> Дополнительный параметры -> «Дополнительно : Переменная среда» В системных переменных найти «Path» D:\OpenServer\modules\php\PHP-7.2*64

spoiler

Но в cmd теперь ругается на отсутствие кучи библиотек PHP Warning: PHP Startup: Unable to load dynamic library 'php_mbstring.dll' (tried: w:/modules/php/PHP-7.2-x64/ext/php_mbstring.dll (▒▒ ▒▒▒▒▒▒ ▒▒▒▒▒▒▒▒▒ ▒▒▒▒▒▒. ), w:/modules/php/PHP-7.2-x64/ext/php_php_mbstring.dll.dll (▒▒ ▒▒▒▒▒▒ ▒▒▒▒▒▒▒▒▒ ▒▒▒▒▒▒. )) in Unknown on line 0 PHP Warning: PHP Startup: Unable to load dynamic library 'php_bz2.dll' (tried: w:/modules/php/PHP-7.2-x64/ext/php_bz2.dll (▒▒ ▒▒▒▒▒▒ ▒▒▒▒▒▒▒▒▒ ▒▒▒▒▒▒. ), w:/modules/php/PHP-7.2-x64/ext/php_php_bz2.dll.dll (▒▒ ▒▒▒▒▒▒ ▒▒▒▒▒▒▒▒▒ ▒▒▒▒▒▒. )) in Unknown on line 0 PHP Warning: PHP Startup: Unable to load dynamic library 'php_curl.dll' (tried: w:/modules/php/PHP-7.2-x64/ext/php_curl.dll (▒▒ ▒▒▒▒▒▒ ▒▒▒▒▒▒▒▒▒ ▒▒▒▒▒▒. ), w:/modules/php/PHP-7.2-x64/ext/php_php_curl.dll.dll (▒▒ ▒▒▒▒▒▒ ▒▒

В папке php 7.2 *62 они имеются, в конфиге не закомментированы. В сети есть вариант их закоментировать, но к примеру mbstring у меня используется в другом проекте. т.е. не самый лучший вариант править config под каждый проект.

А также error в консоли:

[Composer\Exception\NoSslException]
The openssl extension is required for SSL/TLS protection but is not available. If you can not enable the openssl ex
tension, you can disable this error, at your own risk, by setting the ‘disable-tls’ option to true.

Форум

Здравствуйте, мне нужна помощь с изменением версии php в настройках. Если я ни ошибаюсь, то после того, как я изменю версию php, ещё нужно будет редактировать какие-то там файлы — можно по подробнее об этом.

Максим Сообщения: 6027 Зарегистрирован: 11 дек 2010, 20:29
Russlav писал(а): Если я ни ошибаюсь
Ошибаетесь.
Russlav Сообщения: 50 Зарегистрирован: 03 окт 2015, 23:10 Откуда: Краснодар

Изображение

Так что, я могу изменить версию php в настройках, и всё будет работать?

Максим Сообщения: 6027 Зарегистрирован: 11 дек 2010, 20:29
Russlav писал(а): Так что, я могу изменить версию php в настройках, и всё будет работать?

Изменить можете, а будут ли после этого работать ваши скрипты или нет зависит от того поддерживают ли они выбранную версию PHP.

Russlav Сообщения: 50 Зарегистрирован: 03 окт 2015, 23:10 Откуда: Краснодар

Максим писал(а): Изменить можете, а будут ли после этого работать ваши скрипты или нет зависит от того поддерживают ли они выбранную версию PHP.

О каких скриптах идёт речь?

[upd=1447783283][/upd]
И не могли бы вы помощь мне в этой теме /viewtopic.php?f=7&t=2301

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *